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Date Apr 11, 14
SIMCA®-online 13.1
Problem

SIMCA®-online clients stops updating, displays Not Responding in window title (Q798)

Symptoms:

All SIMCA®-online clients connected to a server become unresponsive. Plots can no longer be opened, already opened plots are no longer updated, it is not possible to connect to the server, "Not Responding" is shown in the caption of the client, the client is disconnected from the server.

At the same time the CPU usage for the SIMCA®-online server service drops to near 0%, the only thing written to the server log is "Tested all (N) client connections" if the server log level is set to Debug.

This can happen at any time, but usually after any of the following things are done:

  • Opening or refreshing the Open dialog
  • Opening or refreshing the Project Administration dialog
  • Opening or refreshing the Server Audit Trail
  • Opening a configuration
  • Adding a folder, workspace, project or configuration
  • Deleting a folder, workspace, project or configuration
  • Renaming a folder, workspace or configuration
  • Starting or stopping the execution for a configuration

The likelihood for this happening also increases with the number of connected clients and configurations on the server.

Cause:

The SIMCA®-online server has encountered a full system deadlock when a client requests information related to a project.

Resolution:

When this happens the server process has to be stopped and restarted. Note that no data-loss occurs because of this problem, the server will catch-up any previous activity when it is restarted, following the settings for catch-up of the configurations on the server.

Workaround:

Reduce the above listed activities, if possible.

Status:

Fixed in SIMCA®-online 13.2 and later, and also in the SIMCA®-online 13.1.1 patch described in KB article Q799.

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