Unpredicted batches within the Catch-Up time range are not predicted when execution is turned on (Q828)
Symptoms:
Historical batches (batches that have both a start and end time) that exist in a data source are not automatically predicted when execution is turned on for a batch configuration in SIMCA®-online, even though the batches are within the Catch-Up time range of the configuration.
Here is an example which demonstrates this issue:
- Execution for a project configuration has been turned off the last 24 hours so SIMCA®-online hasn't been predicting any data.
- The Catch-Up time range is set to 5 hours for this configuration
- Assume the following batch exist in the data source:
- Batch1. This is a one hour long batch that ended one hour ago.
- Batch2. This is a batch that started just 15 minutes ago. It is still active (has not got an end time).
- You start execution for the configuration, and expect Batch1 to be predicted, but it isn't. However Batch2 is picked up because it is active when execution was started.
Note: Continuous configurations are not affected by this issue.
Cause:
The Catch-Up time range is not working as it was designed to. This was an unintentional side-effect of another change in the execution algorithm for the SIMCA®-online 13.2 release. See http://www.umetrics.com/kb/execution-ignores-batch-node-start-time-and-executes-batch-start-time-future
Workaround:
Do a manual repredict of the missed batches.
Status:
This problem is fixed in SIMCA®-online 13.2.1 (Q830), SIMCA®-online 13.3.1 (Q831) and SIMCA®-online 14.0 (Q846).
More Information:
For full details on the SIMCA®-online execution algorithm, see chapter 6 in the SIMCA®-online Technical Guide.